$re = '/(.*?)(\w*)\[([^\[\]]+)\](.*)/m';
$str = 'utvk[fvu,gn[u,k,r],nl,q[t[ij,lo[z,x]],bm]]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);