$re = '/bash-1.(hello):*.0/m';
$str = 'bash-1.(hello):1.0';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);