re = /Audit (?P<audit_outcome>(Success|Failure)),(?P<log_date>.*),Microsoft-Windows-Eventlog,(?P<event_id>\d+),(?P<category>.*),(?P<event_message>.*)/
str = 'Audit Success,08/08/2017 16:22:09,Microsoft-Windows-Eventlog,1100,Service shutdown,The event logging service has shut down.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end