#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<isbn:>\s+([\d-]+)"
Local $sString = "var response=[];//ютф8" & @CRLF & _
"var _iddb="1";" & @CRLF & _
"var _basequant="2391872";" & @CRLF & _
"var _flag45="yes";" & @CRLF & _
"response[0]= {" & @CRLF & _
" _size: "1"," & @CRLF & _
" _result_0: {" & @CRLF & _
" _isn: "1606361"," & @CRLF & _
" _id: "SKBM-SZAO-RU/CBS_SZAO/IBIS/117439"," & @CRLF & _
" _level: "Full"," & @CRLF & _
" _iddb: "1"," & @CRLF & _
" _sourceIddb: "1"," & @CRLF & _
" _archive: "false"," & @CRLF & _
" _controlType: "UNDEFINE"," & @CRLF & _
" _status: "NEW"," & @CRLF & _
" _FULLFORM_0: [" & @CRLF & _
""<Автор:>[i class=RP]Кононов, Николай[/i]"," & @CRLF & _
""<Основное заглавие:> Код Дурова"," & @CRLF & _
""<Сведения, относящ. к заглавию:> реальная история ВКонтакте и ее создателя"," & @CRLF & _
""<Ответственность:> Н. Кононов"," & @CRLF & _
""<Место издания:> Москва"," & @CRLF & _
""<Издательство:> [i class=PU]Манн, Иванов и Фербер[/i]"," & @CRLF & _
""<Дата издания:> 2013"," & @CRLF & _
""<Объем:> 188, [19] с."," & @CRLF & _
""<Аннотация:>Павел Дуров почти не общается с журналистами, но автору этой книги удалось проникнуть внутрь ВКонтакте. Получилось не просто журналистское расследование, а авантюрная история, исследующая феномен сетевого предпринимателя-харизматика и его детища, а заодно и вполне материальное выражение популярности бизнеса соцсети."," & @CRLF & _
""<isbn:> 978-5-91657-546-0"," & @CRLF & _
"""" & @CRLF & _
" ]" & @CRLF & _
" }," & @CRLF & _
" _iddb_0: {" & @CRLF & _
" _number: "1"," & @CRLF & _
" _title: "Сводный каталог"" & @CRLF & _
" }" & @CRLF & _
" };" & @CRLF & _
"var test=1;//ютф8" & @CRLF & _
"</isbn:>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")