import Foundation
let pattern = #"\b(DE(?:\s*[0-9]){20}|AT(?:\s*[0-9]){18})\b(?!\s*[0-9])"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ###################"""
################## Germany IBAN ##################
DE89 3704 0044 0532 0130 00
DE59290501010001149590
DE62500105179628448387
DE55500105172374652131
DE50500105176152274153
DE 0712 3412 3412 3412 3412
DE07 1234 1234 1234 1234 12
DE07 1234 1234 1234 123412
Mashine friendly DE07123412341234123412 style
This format DE07 1234 1234 1234 1234 12 is given by DIN
Human DE07 1234 1234 1234 123412 readable
Not good DE07 12341234 1234123412 readable
################## Austrian IBAN ##################
AT61 1904 3002 3457 3201
"""###################
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)