#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b(?:DE|AT)(?:\s?[0-9a-zA-Z]){18}(?:(?:\s?[0-9a-zA-Z]){2})?\b"
Local $sString = "################## Germany IBAN ##################" & @CRLF & _
"DE89 3704 0044 0532 0130 00" & @CRLF & _
"DE59290501010001149590" & @CRLF & _
"DE62500105179628448387" & @CRLF & _
"DE55500105172374652131" & @CRLF & _
"DE50500105176152274153" & @CRLF & _
"IBAN: DE59290501010001149590" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"DE 0712 3412 3412 3412 3412" & @CRLF & _
"DE07 1234 1234 1234 1234 12" & @CRLF & _
"DE07 1234 1234 1234 123412" & @CRLF & _
"" & @CRLF & _
"Mashine friendly DE07123412341234123412 style" & @CRLF & _
"This format DE07 1234 1234 1234 1234 12 is given by DIN" & @CRLF & _
"Human DE07 1234 1234 1234 123412 readable" & @CRLF & _
"Not good DE07 12341234 1234123412 readable" & @CRLF & _
"" & @CRLF & _
"################## Austrian IBAN ##################" & @CRLF & _
"AT61 1904 3002 3457 3201" & @CRLF & _
"AT59290501010001149590" & @CRLF & _
"AT62500105179628448387" & @CRLF & _
"AT55500105172374652131" & @CRLF & _
"AT50500105176152274153" & @CRLF & _
"" & @CRLF & _
"AT 0712 3412 3412 3412 3412" & @CRLF & _
"AT07 1234 1234 1234 1234 12" & @CRLF & _
"AT07 1234 1234 1234 123412" & @CRLF & _
"" & @CRLF & _
"Mashine friendly AT07123412341234123412 style" & @CRLF & _
"This format AT07 1234 1234 1234 1234 12 is given by DIN" & @CRLF & _
"Human AT07 1234 1234 1234 123412 readable" & @CRLF & _
"Not good AT07 12341234 1234123412 readable" & @CRLF & _
"" & @CRLF & _
"################## Not Valid IBAN ##################" & @CRLF & _
"USt-IdNr.: DE310453183" & @CRLF & _
"eingetragen " & @CRLF & _
"" & @CRLF & _
"Tax number: DE310453183" & @CRLF & _
"eingetragen" & @CRLF & _
"" & @CRLF & _
"Tax number: DE310453183eingetragen" & @CRLF & _
"" & @CRLF & _
"Tax number: AT310453183introduce" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")