$re = '/(?<=см)\s*((?i:d=?\s*)?\d+(?:\.\d+)?\s*(?:см)?)/m';
$str = 'Салатник 600 мл h= 4.7 см 19.3см 19.3 см d 19.3 см d=19.3 см D=19.3 600 мл';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);