re = /rmi:\/\/[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}/m
str = '{"jmx.serviceUrl": "service:jmx:rmi:///jndi/rmi://172.123.523.1:1099/obj"}}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end