$re = '/border.*?#\s*(.*);\s*\//m';
$str = '
border: 2px solid #a4002c; /**/
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);