package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\w*ere\b`)
var str = `ere
conifere
realiniere
asdas
eretic
ereditate
serenada`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}