$re = '/#?\w+(?:-\w+)*/m';
$str = 'Test a#words 100-200-300
Test #words 100-200-300
Test ##words 100-200-300';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);