import re
regex = re.compile(r"(url\(\\?['\"]?)(.*?)(\\?['\"]?\))", flags=re.IGNORECASE)
test_str = ("/* stylelint-disable indentation */\n\n"
"/// Plasma design theme icons\n"
"@font-face {\n"
" @include font-weight(regular);\n"
" font-family: 'custom-icons';\n"
" font-style: normal;\n"
" src: url(\\\"/assets/img/raster-matrix-top-to-bottom.svg\\\")\n"
" format('woff'),\n"
" url('~@com.mgmtp.a12/plasma-design/assets/fonts/customicons/custom-icons.ttf')\n"
" format('truetype');\n"
"}\n\n"
"/// Material design icons\n"
"@font-face {\n"
" @include font-weight(regular);\n"
" font-family: 'Material Icons';\n"
" font-style: normal;\n"
" src: url('/assets/fonts/material-design-icons/MaterialIcons-Regular.eot')\n"
" format('eot'),\n"
" url('/assets/fonts/material-design-icons/MaterialIcons-Regular.woff2')\n"
" format('woff2'),\n"
" url('/assets/fonts/material-design-icons/MaterialIcons-Regular.woff')\n"
" format('woff'),\n"
" url('/assets/fonts/material-design-icons/MaterialIcons-Regular.ttf')\n"
" format('truetype');\n"
"}\n\n"
"/// Avenir\n"
"/// Regular\n"
"@font-face {\n"
" @include font-weight(regular);\n"
" font-family: 'Avenir';\n"
" font-style: normal;\n"
" src: url(\\\"/assets/img/raster-matrix-top-to-bottom.svg\\\") format('eot'),\n"
" url('/assets/fonts/avenir/avenir-regular.woff2') format('woff2'),\n"
" url('/assets/fonts/avenir/avenir-regular.woff') format('woff'),\n"
" url('/assets/fonts/avenir/avenir-regular.ttf') format('truetype');\n"
"}\n\n"
"/// Avenir\n"
"/// Demi\n"
"@font-face {\n"
" @include font-weight(demi);\n"
" font-family: 'Avenir';\n"
" font-style: normal;\n"
" src: url('/assets/fonts/avenir/avenir-demi.eot') format('eot'),\n"
" url('/assets/fonts/avenir/avenir-demi.woff2') format('woff2'),\n"
" url('/assets/fonts/avenir/avenir-demi.woff') format('woff'),\n"
" url('/assets/fonts/avenir/avenir-demi.ttf') format('truetype');\n"
"}\n\n"
"/// Avenir\n"
"/// Medium\n"
"@font-face {\n"
" @include font-weight(medium);\n"
" font-family: 'Avenir';\n"
" font-style: normal;\n"
" src: url('/assets/fonts/avenir/avenir-medium.eot') format('eot'),\n"
" url('/assets/fonts/avenir/avenir-medium.woff2') format('woff2'),\n"
" url('/assets/fonts/avenir/avenir-medium.woff') format('woff'),\n"
" url('/assets/fonts/avenir/avenir-medium.ttf') format('truetype');\n"
"}\n\n"
"/* stylelint-enable indentation */\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")