import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:\\+62|\\(0\\d{2,3}\\)|0)\\s?(?:361|8[17]\\s?\\d?)?(?:[ -]?\\d{3,4}){2,3}$";
final String string = "+62 361 222777\n"
+ "+62 813-444-5555\n"
+ "+62 812-3333-3333\n"
+ "+62 811 391 2103\n"
+ "+62 361-2277777\n"
+ "(0361) 227337\n"
+ "+62 8113912103\n"
+ "08134455555\n"
+ "0361-2277777\n"
+ "+62 812 3333 3333\n"
+ "+62 877 80803550\n"
+ "081339222111\n"
+ "081 339 222 111\n"
+ "+62 811338429196";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}