#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "```[\S\s]*?```"
Local $sString = "## 使用指南 (Usage)" & @CRLF & _
"" & @CRLF & _
"**下载使用**" & @CRLF & _
"```js" & @CRLF & _
"git clone https://github.com/BiYuqi/webpack-seed.git" & @CRLF & _
"" & @CRLF & _
"cd webpack-seed" & @CRLF & _
"" & @CRLF & _
"npm install" & @CRLF & _
"```" & @CRLF & _
"" & @CRLF & _
"**本地开发(dev)**" & @CRLF & _
"```js" & @CRLF & _
"npm run dev" & @CRLF & _
"```" & @CRLF & _
"" & @CRLF & _
"**打包(build)**" & @CRLF & _
"" & @CRLF & _
"* 默认情况下,该配置方案假设你的应用是被部署在一个域名的根路径上例如 https://www.my-app.com/" & @CRLF & _
"* 如果应用被部署在一个子路径上,你就需要用这个选项指定这个子路径" & @CRLF & _
"* 例如,如果你的应用被部署在 https://www.my-app.com/my-app/" & @CRLF & _
"* 则设置 webpack的output.publicPath 为 /my-app/" & @CRLF & _
"* 本项目由于需要临时部署在git-pages预览 所以改配置临时改为/webpack-seed/" & @CRLF & _
"* 普通打包(大部分) npm run build 默认 '/'" & @CRLF & _
"* 该命令具体请看package.json scripts命令配置" & @CRLF & _
"* [配置详情](https://github.com/BiYuqi/webpack-seed/blob/master/webpack.seed.common.js#L13)" & @CRLF & _
"* [scripts命令配置](https://github.com/BiYuqi/webpack-seed/blob/master/package.json#L8)" & @CRLF & _
"" & @CRLF & _
"```js" & @CRLF & _
"// 普通打包(大部分) npm run build publicPath默认 '/'" & @CRLF & _
"npm run build" & @CRLF & _
"" & @CRLF & _
"// 打包时 npm run build:git 该命令会打包的路径会自动带上github项目地址/webpack-seed/" & @CRLF & _
"//(当发布环境不是服务器根路径,都可以采用该方案,只需更改路径名称即可,本项目二级路径为webpack-seed)" & @CRLF & _
"npm run build:git" & @CRLF & _
"" & @CRLF & _
"```" & @CRLF & _
"**依赖分析**" & @CRLF & _
"```js" & @CRLF & _
"// 利用webpack-bundle-analyzer 进行代码构建分析" & @CRLF & _
"" & @CRLF & _
"npm run analyzer" & @CRLF & _
"```" & @CRLF & _
"" & @CRLF & _
"**测试**" & @CRLF & _
"```js" & @CRLF & _
"// karma mocha chai" & @CRLF & _
"npm run test" & @CRLF & _
"```" & @CRLF & _
"" & @CRLF & _
"## 开发规范 (Standard)" & @CRLF & _
"" & @CRLF & _
"查看[INSTRODUCTION](https://github.com/BiYuqi/webpack-seed/blob/master/INSTRODUCTION.md)" & @CRLF & _
"" & @CRLF & _
"## 接口配置 (Api Setting)" & @CRLF & _
"" & @CRLF & _
"查看[API/README](https://github.com/BiYuqi/webpack-seed/blob/master/src/api/README.md)" & @CRLF & _
"" & @CRLF & _
"## 目录结构 (Source)" & @CRLF & _
"" & @CRLF & _
"查看[INSTRODUCTION](https://github.com/BiYuqi/webpack-seed/blob/master/INSTRODUCTION.md#%E7%9B%AE%E5%BD%95%E7%BB%93%E6%9E%84-source)" & @CRLF & _
"" & @CRLF & _
"## 输出目录 (Output)" & @CRLF & _
"[查看输出](https://github.com/BiYuqi/webpack-seed/tree/gh-pages)" & @CRLF & _
"* dist/" & @CRLF & _
"* ---html" & @CRLF & _
"* ---image" & @CRLF & _
"* ---media" & @CRLF & _
"* ---css" & @CRLF & _
"* ---js" & @CRLF & _
"* ---lib" & @CRLF & _
"* ---index.html" & @CRLF & _
"" & @CRLF & _
"> 注意:如果有音视频等,会被打包在media目录" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"## TODO" & @CRLF & _
"- [x] 添加ejs模板,进行页面(首尾)复用, 页面功能模板渲染" & @CRLF & _
"- [x] mini-css-extract-plugin 提取js内引入scss文件失败, 打包后依然在js文件(已解决)" & @CRLF & _
"- [x] 首页页面模板未完成(单独处理打包)" & @CRLF & _
"- [x] 添加第三方库以链接的方式引入" & @CRLF & _
"- [x] 增加ESLint代码校验" & @CRLF & _
"- [x] 增加两个文件夹,一个是fix IE兼容, 一个是引入的公用库,自动加载第三方库到页面,避免手动填写" & @CRLF & _
"- [x] 增加网站未登录的模板(无header,footer)" & @CRLF & _
"- [x] 添加多样化layout模板支持(示例layout/layoutAuth)" & @CRLF & _
"- [x] 搭建单元测试环境(基于karma mocha chai)" & @CRLF & _
"- [x] 单独抽离配置文件webpack.seed.common.js" & @CRLF & _
"- [ ] 待完善测试用例编写" & @CRLF & _
"- [ ] 添加doc使用说明以及实现思路解析" & @CRLF & _
"" & @CRLF & _
"## DOING" & @CRLF & _
"- [ ] 添加doc使用说明以及实现思路解析" & @CRLF & _
"" & @CRLF & _
"## LONG TODO(Base on master)" & @CRLF & _
"- [ ] 搭建国际化版本" & @CRLF & _
"- [ ] 建立分支web-system (后台管理系统模板)" & @CRLF & _
"- [ ] 添加完整网站demo示例" & @CRLF & _
"- [ ] 大众网站模板" & @CRLF & _
"- [ ] web-mobile(移动端模板)" & @CRLF & _
"" & @CRLF & _
"## 更新日志 (Update log)" & @CRLF & _
"" & @CRLF & _
"查看[CHANGELOG](https://github.com/BiYuqi/webpack-seed/blob/master/CHANGELOG.md)" & @CRLF & _
"" & @CRLF & _
"> 本项目目前接口(使用axios只能支持到IE10+), 项目本身支持IE9+" & @CRLF & _
"" & @CRLF & _
"## 贡献代码" & @CRLF & _
"* 先 Fork (https://github.com/BiYuqi/webpack-seed/fork)" & @CRLF & _
"* 创建分支 (git checkout -b your-idea)" & @CRLF & _
"* 提交更改 (git commit -am 'Fixed something')" & @CRLF & _
"* 推送更改 (git push origin your-idea)" & @CRLF & _
"* 创建一个 Pull Request" & @CRLF & _
"" & @CRLF & _
"> [Pull Request使用](http://www.ruanyifeng.com/blog/2017/07/pull_request.html)" & @CRLF & _
"" & @CRLF & _
"## 参考(Thanks)" & @CRLF & _
"" & @CRLF & _
"本脚手架开发中,ejs模板渲染实现这块参考了[webpack-seed](https://github.com/Array-Huang/webpack-seed), 特此备注"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")