$re = '/^(?:[A-Z]+ - \K)?.*\S/m';
$str = 'AAA - Something Here
AAA - Something Here - D
Something Here ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);