package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)[bcdfghjklmnpqrstvwxyz]{7,}`)
var str = `gffdsfsAsfdUgfh`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}