#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mx)(?(DEFINE)" & @CRLF & _
" (?<marker>\b[A-Z][-\w]*\b)" & @CRLF & _
" (?<ws>[\ \t]+)" & @CRLF & _
" (?<needle>\b(?:Study|Test))" & @CRLF & _
"" & @CRLF & _
" (?<pre>(?:(?&marker)(?&ws))+)" & @CRLF & _
" (?<post>(?:(?&ws)(?&marker))+)" & @CRLF & _
"" & @CRLF & _
" (?<before>(?&pre)(?&needle))" & @CRLF & _
" (?<after>(?&needle)(?&post))" & @CRLF & _
" (?<both>(?&pre)(?&needle)(?&post))" & @CRLF & _
")" & @CRLF & _
"" & @CRLF & _
"(?&both)|(?&before)|(?&after)"
Local $sString = "" & @CRLF & _
"" & @CRLF & _
"I have been analyzing large amounts of text data. This is what I got so far:" & @CRLF & _
"" & @CRLF & _
"(([A-Z][\w-]*)+\s+(\b(Study|Test)\b)(\s[A-Z][\w-]*)*)|(\b(Study|Test)\b)(\s[A-Z][\w-]*)+" & @CRLF & _
"" & @CRLF & _
"Types of phrases I would like to capture:" & @CRLF & _
"" & @CRLF & _
" Europe National Longitudinal Study" & @CRLF & _
" Longitudinal Study" & @CRLF & _
" Study Initiative" & @CRLF & _
" Longitudinal Study Initiative" & @CRLF & _
"" & @CRLF & _
"I want to capture the word 'Study' or 'Test' ONLY if it is surrounded by the words starting with a capital letter. The ideal regex would achieve all of this + it would ignore\escape certain words like 'of' or 'the'." & @CRLF & _
"" & @CRLF & _
" *the above regex is super slow with the str.findall function, I guess there must be a better solution" & @CRLF & _
" ** I used https://regex101.com for testing and then run it in Jupyter, Python 3" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")