#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^ {0,3}((?:(`){3,}?)|(?:(~){3,}?))(?!\2\3)(?:([^`\n]+?)(\1(?:\2\3)*)|(?:( *([^ \n]+)[^`\n]*)?\n([\s\S]*?)(^ {0,3}))(\1(?:\2\3)*)(?=$))"
Local $sString = "```js" & @CRLF & _
"var test = 'test';" & @CRLF & _
"```" & @CRLF & _
"" & @CRLF & _
"```js" & @CRLF & _
"var x = "John Doe";" & @CRLF & _
"console.log( x );" & @CRLF & _
"```"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")