#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:(?i)(?:https:|http:)?\/\/)?(?:(?i)(?:www\.youtube\.com\/(?:embed\/|watch\?v=)|youtu\.be\/|youtube\.googleapis\.com\/v\/)(?<YoutubeID>[a-z0-9-_]{11,12})|(?:vimeo\.com\/|player\.vimeo\.com\/video\/)(?<VimeoID>[0-9]+))"
Local $sString = "https://www.youtube.com/embed/123456789012" & @CRLF & _
"https://www.youTUbe.com/embed/123456789012" & @CRLF & _
"http://www.youtube.com/watch?v=My2FRPA3Gf8" & @CRLF & _
"htTp://www.youtube.com/watch?V=My2FRPA3Gf8" & @CRLF & _
"http://youtu.be/My2FRPA3Gf8" & @CRLF & _
"http://youTU.be/My2FRPA3Gf8" & @CRLF & _
"https://www.youtu.be/embed/123456789012" & @CRLF & _
"https://youtube.googleapis.com/v/123456789012" & @CRLF & _
"https://youtube.googleAPis.com/v/123456789012" & @CRLF & _
"https://youtube.googleapis.com/embed/123456789012" & @CRLF & _
"https://www.youtube.com/embed/123456789012" & @CRLF & _
"http://www.youtube.com/embed/123456789012" & @CRLF & _
"//www.youtube.com/embed/123456789012" & @CRLF & _
"www.youtube.com/embed/123456789012" & @CRLF & _
"" & @CRLF & _
"http://vimeo.com/25451551" & @CRLF & _
"http://player.vimeo.com/video/25451551" & @CRLF & _
"" & @CRLF & _
"https://player.vimeo.com/video/6969232737373733383782383273287328327342873" & @CRLF & _
"http://player.vimeo.com/video/6969" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")