$re = '/^\d+(?:\.\d+)?$/m';
$str = '1545.55
-> true
15424.55.44
-> false';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);