# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"""
(?mnxs-i)
^
(?!$)
(?<Thousands>
M{0,3}
)
(?<Hundreds>
(
(C(M|D))
(?!C)
|
D
)?
C{0,3}
)
(?<Tens>
(
(X(C|L))
(?!X)
|
L
)?
X{0,3}
)
(?<Ones>
(
(I(X|V))
(?!I)
|
V
)?
I{0,3}
)
$
"""
test_str = ("MMMDCCCLXXXVIII\n"
"MMMCDXLIV\n\n"
"50 Valid\n"
"I\n"
"MMMCMXCIX\n"
"MMDCLXXIV\n"
"MCDXCIX\n"
"CCCXVIII\n"
"XCII\n"
"MMMLXXXIV\n"
"MMMCMLIII\n"
"DCCXXX\n"
"DCXCV\n"
"CCXCV\n"
"MMDCLX\n"
"MDCCLXXVI\n"
"CDXLV\n"
"MMMCDXLII\n"
"CMXXI\n"
"MDCCCXC\n"
"MMCCCXLVII\n"
"MCMXXXVIII\n"
"CDXCII\n"
"MMMCMXXII\n"
"DCXLVIII\n"
"MCDLVI\n"
"DCCLXXXIX\n"
"MMXIV\n"
"MCMXC\n"
"CCCLXXI\n"
"MDCCCXXI\n"
"MMCMLIV\n"
"MDCXVI\n"
"MMCMXLV\n"
"MCDLXXIX\n"
"DCCCXIII\n"
"CCXLVII\n"
"MDCCCXCV\n"
"MMCMLXXXVIII\n"
"CDLX\n"
"MMCDLIII\n"
"CMXLV\n"
"DCCXXII\n"
"MMMDCCL\n"
"CDXXVIII\n"
"MMDXLII\n"
"DCCCXCIX\n"
"MMXLI\n"
"CMXLIX\n"
"MCDXXXIX\n\n"
"50 Invalid\n"
"IIII\n"
"VV\n"
"LL\n"
"DD\n"
"XXXX\n"
"CCCC\n"
"MMMM\n"
"IIV\n"
"IIIV\n"
"VX\n"
"VL\n"
"VC\n"
"XD\n"
"XM\n"
"IL\n"
"IC\n"
"ID\n"
"IM\n"
"MCMC\n"
"IXX\n"
"XCC\n"
"IIC\n"
"CDM\n"
"CDC\n"
"MIM\n"
"IXL\n"
"ILX\n"
"ICX\n"
"IICM\n"
"IIIC\n"
"IIIM\n"
"XIC\n"
"XIXX\n"
"XIXC\n"
"IXXC\n"
"CMCM\n"
"CDCD\n"
"XCXC\n"
"XLXL\n"
"MDCM\n"
"DCD\n"
"IXXL\n"
"XLC\n"
"VIX\n"
"VID\n"
"VIL\n"
"IIVX\n"
"IVXL\n"
"MXLIVC\n"
"CXM\n")
matches = re.finditer(regex, test_str, re.MULTILINE | re.VERBOSE | re.DOTALL)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.