re = /^(?:[^+\n]*\+){3}.*/m
str = '+1a
+1a +2
+1a +2 +3
+1a +2 +3 +4
+1a +2 +3 +4 +5'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end