const regex = /^(?=(?:[^+\n]*\+){3}).*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=(?:[^+\\n]*\\+){3}).*', 'gm')
const str = `+1a
+1a +2
+1a +2 +3
+1a +2 +3 +4
+1a +2 +3 +4 +5`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}