$re = '/\w:.+?\.\w+/';
$str = '(C:\\Users\\Gleb\\Desktop\\сайты.txt,C:\\Users\\Gleb\\Desktop\\istock_000020116885large_-_copy-700x461.jpg)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);