re = /\d+\s+-[^-]*(?=\s)/m
str = '"Opcao 01 - Frase aleatória - Menu Superior",
"Opcao 02 - Outra Frase aleatória - Menu Su",
"Opcao 03 - Mais 01 Frase - Menu",
"Opcao 04 - Mais Frase -",
"Opcao 05 - Frase Simples",'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end