package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:[\w+'\.\-\s]*?([\w'-]+))(?:,.*?)*? tells the group, 'blah'$`)
var str = `Magi-cal Prin'cess Sab'ri-ne, the dragon violating sorceresss tells the group, 'blah'`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}