$re = '/(?<code>.*;)\s*(?<object>.*)\./im';
$str = 'asmka
asnku
asmka.radio.transmitRaw
asmka.radio.transmitSDLP
console.log(asmka.mode)
cosnole.log(asmka.radio.cw)
console.log("1");
console.log("1"); console.log("2");
console.log("1"); console.log("2"); console.asmka
console.log("1"); console.log("2"); console.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);