import Foundation
let pattern = #"(\b(ZVSEBACT|ZVSEBADD)[A-Z,0-9]{2}\.PACS_\.0230\.)(.*?)\.EBA\.(S202(SCT|COR))([A-Z,0-9]{8})(?=\.I\b)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"ZVSEBACTAA.PACS_.0230.[YYYYMMDDhhmmss].[Q5].EBA.S202SCTAAAAAAAA.I ZVSEBADD11.PACS_.0230.[YYYYMMDDhhmmss].[Q5].EBA.S202COR11111111.I"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)