package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)Ková(č|cs|c)`)
var str = `Kováč
Kovács
Kovác
Kováčik`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}