re = /(?m)(?<Changed>^[^-]*$)/m
str = 'Changed Attributes:
SAM Account Name: -
Display Name: -
User Principal Name: -
Home Directory: -
Home Drive: -
Script Path: -
Profile Path: -
User Workstations: -
Password Last Set: -
Account Expires: -
Primary Group ID: -
AllowedToDelegateTo: -
Old UAC Value: 0x19A11
New UAC Value: 0x19811
User Account Control:
\'Don\'t Expire Password\' - Disabled
User Parameters: -
SID History: -
Logon Hours: -
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end