$re = '/(?<=\b\d+)(?=V(?:[\s,-]|$))/m';
$str = 'Split XXTX99V 23...490V -23V 34-499V';
$subst = " ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;