$re = '/.*img.*src="[^"]*\/?(.*\s+.*\.(?:png|jpeg|jpg|gif|bmp))"/Ui';
$str = '<img style="width:145px;" src="https://www.glvar.com/agentpics/Krist a B.jpg" border="0">';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);