$re = '/^(\d{2,4}\/?)+/m';
$str = '22/04/2020 14:10 by example@example.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);