import re
regex = re.compile(r"([A-G][1-3])([^A-G]*(?:[A-G](?![1-3])[^A-G]*)*)")
test_str = "A1 ACBFEKJRQ0Z+-F2.,12STLMGHDF19)(D2!?56WXPC1IONVU43\\\"\\'E1Y87><A3-=.,\\'\\\"!?><()@"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")