using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<form.+action=""(.*?)"".*>\n.*?<input.*?value=""(.*?)"".*>\n.*?<input.*?value=""(.*?)"".*>\n.*?<input.*?value=""(.*?)""|<input id=""(.*?)""|<input name=""(.*?)""";
string input = @"<form accept-charset=""UTF-8"" action=""https://appname.infusionsoft.com/app/form/process/6488f3cca2ac451a9d4f416c48f4c3bc"" class=""infusion-form"" id=""inf_form_6488f3cca2ac451a9d4f416c48f4c3bc"" method=""POST"">
<input name=""inf_form_xid"" type=""hidden"" value=""6488f3cca2ac451a9d4f416c48f4c3bc"" />
<input name=""inf_form_name"" type=""hidden"" value=""Regex Text Webform"" />
<input name=""infusionsoft_version"" type=""hidden"" value=""1.70.0.369835"" />
<div class=""infusion-field"">
<label for=""inf_field_FirstName"">Vorname</label>
<input id=""inf_field_FirstName"" name=""inf_field_FirstName"" placeholder=""Vorname"" type=""text"" />
</div>
<div class=""infusion-field"">
<label for=""inf_field_Email"">Email *</label>
<input id=""inf_field_Email"" name=""inf_field_Email"" placeholder=""Email *"" type=""text"" />
</div>
<div class=""infusion-field"">
<label for=""inf_field_Phone1"">Phone 1</label>
<input id=""inf_field_Phone1"" name=""inf_field_Phone1"" placeholder=""Phone 1"" type=""text"" />
</div>
<div class=""infusion-field"">
<label for=""inf_custom_WebinarTitel0"">Webinar Titel</label>
<input id=""inf_custom_WebinarTitel0"" name=""inf_custom_WebinarTitel0"" placeholder=""Webinar Titel"" type=""text"" />
</div>
<div class=""infusion-field"">
<label for=""inf_custom_WebinarTeilnahmelink0"">Webinar Teilnahmelink *</label>
<input id=""inf_custom_WebinarTeilnahmelink0"" name=""inf_custom_WebinarTeilnahmelink0"" placeholder=""Webinar Teilnahmelink *"" type=""text"" />
</div>
<input name=""inf_field_LeadSourceId"" type=""hidden"" value=""null"" />
<input name=""inf_custom_Quelle"" type=""hidden"" value=""null"" />
<div>
<div> </div>
</div>
<div class=""infusion-submit"">
<button class=""infusion-recaptcha"" id=""recaptcha_6488f3cca2ac451a9d4f416c48f4c3bc"" type=""submit"">Los gehts!</button>
</div>
</form>
<script type=""text/javascript"" src=""https://appname.infusionsoft.app/app/webTracking/getTrackingCode""></script>
<script type=""text/javascript"" src=""https://appname.infusionsoft.com/resources/external/recaptcha/production/recaptcha.js?b=1.70.0.369835-hf-202106081103""></script>
<script src=""https://www.google.com/recaptcha/api.js?onload=onloadInfusionRecaptchaCallback&render=explicit"" async=""async"" defer=""defer""></script>
<script type=""text/javascript"" src=""https://appname.infusionsoft.com/app/timezone/timezoneInputJs?xid=6488f3cca2ac451a9d4f416c48f4c3bc""></script>
<script type=""text/javascript"" src=""https://appname.infusionsoft.com/js/jquery/jquery-3.3.1.js""></script>
<script type=""text/javascript"" src=""https://appname.infusionsoft.app/app/webform/overwriteRefererJs""></script>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}