re = /(?<=["&])(?<!_&)\w+(?=:)/m
str = '["abc:def&ghi:jkl"]
["abc:de_&_f:xyz&ghi:jkl"]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end