$re = '/(?<=(?:(?<!_)&(?!_)|"))\w+(?=:)/m';
$str = '["abc:def&ghi:jkl"]
["abc:de_&_f:xyz&ghi:jkl"]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);