import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "import\\s+([^()]+?)\\s+from\\s+(['\"])@(system|service)([^\\/()]+?)\\2";
final String string = "import router from '@system.router1'\n"
+ "import router from @system.router2\n"
+ "import router from \"@system.router3'";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}