package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(<a>.+<\/a>)`)
var str = `<a> text </a> <c> code </c>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}