re = /(?![^<]>)"([^"=]?)"(?!>)/
str = 'abc","abc <span style="a">" "</span>'
subst = '„$1"'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result