$re = '/^(?:Play3|One|Hero12|\b(?:Jan|Feb|Mar|Apr|May|Jun|Jul|Aug|Sep|Oct|Nov|Dec)\d{4}\b)$(*SKIP)(*F)|(?<![\d,])(?![0,]*$)(?:0*\K(?:\d{1,3}(?:,\d{3})+|\d{1,4}))$/m';
$str = 'Play3
1,715,455
123,777
One
23,000
etet55
Hero12
vrtg1,345
vrtg001,345
2
Jan2003
0000
0001
12345
45,77
45,777
045,777
Jan2003
03,1
0,1
0,000
0,001
';
$subst = "\n$0";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;