package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^.*\p{Lu}\S+`)
var str = `John Doe
John Doe waves
Bakary N'Diaye says hello
Iván Aguilar goes well
Cisteró shot
Dan I Soylu shots
Mike van der Hoorn with a cross
M.J. Williams takes a shot
Donny van de Beek left foot
Mike van der Hoorn hello
Artak G. Grigoryan with through ball
Trent Alexander-Arnold after a break `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}