$re = '/^(#)/m';
$str = '# Match this
## And this
```
# But not this
```
```code
# Or this
```';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);