use strict;
my $str = '100[leetcode]
';
my $regex = qr/(?<=\S)(?=[\[\]])|(?<=[\[\]])(?=\S)/mp;
my $subst = '\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";