$re = '/(\d{1,2}(\s+\d\/\d)?(\s+x\s+\d{1,2}(\s+\d\/\d)?){1,2})/m';
$str = 'Windscreen 8 x 4 2/3 x 3 2/3 Quarter Sphere (Outer) with Hinge Holes
Windscreen 12 1/3 x 10 2/3 x 3 2/3 Quarter Sphere (Outer) with Hinge Holes
Brick 1 x 4 x 2
Brick 1 x 4
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);