$re = '/(^|[^\d:])(\d{1,2}:\d{2})([^\d:]|$)/m';
$str = '23:45:Description
88:99';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);