$re = '/\b(?!\w*ViewModel\b)\w{2,}Model\b/m';
$str = 'MyModel
MyViewModel
MyView
yModel';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);