re = /\d/m
str = 'abcdefghijklmnopqrstuvwxyz
01234567890
~`!@#$%^&*()_+-=
{}|[]\\;\':",./<>?
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end