#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\d+-\d+-\d+\s\S+)\s+(\w+)\s(\d+)\s---\s(\S+.\S+)\s(\S+\s+:)\s(\S+.*)"
Local $sString = "2019-12-27 13:52:38.201 INFO 1 --- [Thread-8] j.LocalContainerEntityManagerFactoryBean : Closing JPA EntityManagerFactory for persistence unit 'default'" & @CRLF & _
"2019-12-27 13:52:39.535 INFO 1 --- [Thread-8] com.alibaba.druid.pool.DruidDataSource : {dataSource-1} closed" & @CRLF & _
"2019-12-27 13:52:39.538 INFO 1 --- [Thread-8] com.netflix.discovery.DiscoveryClient : Shutting down DiscoveryClient ..." & @CRLF & _
"2019-12-27 13:52:42.539 INFO 1 --- [Thread-8] com.netflix.discovery.DiscoveryClient : Unregistering ..." & @CRLF & _
"2019-12-27 13:52:42.540 WARN 1 --- [DiscoveryClient-0] c.netflix.discovery.TimedSupervisorTask : task supervisor shutting down, can't accept the task" & @CRLF & _
"2019-12-27 13:52:42.597 INFO 1 --- [Thread-8] com.netflix.discovery.DiscoveryClient : Completed shut down of DiscoveryClient" & @CRLF & _
"2019-12-27 13:52:43.329 WARN 1 --- [XNIO-1 task-15] c.n.eureka.resources.InstanceResource : Not Found (Renew): RPLUS-SERVICE-COMMUNITY - 69bce99f652f:rplus-service-community:20090" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")