use strict;
my $str = '05/23/2017 14:19:57.96 id: 0001 seq: 0001 < type: 0009 len: 10 CMD_CHECK_PROTOCOL version: 7
05/23/2017 14:19:57.96 id: 0001 seq: 0001 > type: 8001 len: 72 ANS_OK
05/23/2017 14:19:58.07 id: 0001 seq: 0002 < type: 0001 len: 91 CMD_AUTH sender: 0 type: 4 id: \'admin\'
05/23/2017 14:19:58.07 id: 0001 seq: 0002 > type: 8002 len: 10 ANS_ERR err_code: 0x1
05/23/2017 14:19:58.07 id: 0001 seq: 0001 > type: 000f len: 12 CMD_DISCONNECT reason: 3
05/23/2017 14:20:01.91 id: 0002 seq: 0003 < type: 0009 len: 10 CMD_CHECK_PROTOCOL version: 7
05/23/2017 14:20:01.91 id: 0002 seq: 0003 > type: 8001 len: 72 ANS_OK
05/23/2017 14:20:01.92 id: 0002 seq: 0004 < type: 0001 len: 91 CMD_AUTH sender: 0 type: 4 id: \'admin\'
05/23/2017 14:20:01.92 id: 0002 seq: 0004 > type: 8002 len: 10 ANS_ERR err_code: 0x1
05/23/2017 14:20:01.92 id: 0002 seq: 0001 > type: 000f len: 12 CMD_DISCONNECT reason: 3
05/23/2017 14:24:53.27 id: 0003 seq: 0001 < type: 0009 len: 10 CMD_CHECK_PROTOCOL version: 7
05/23/2017 14:24:53.27 id: 0003 seq: 0001 > type: 8001 len: 72 ANS_OK
05/23/2017 14:24:53.32 id: 0003 seq: 0002 < type: 0001 len: 91 CMD_AUTH sender: 0 type: 4 id: \'Admin\'
05/23/2017 14:24:53.32 id: 0003 seq: 0002 > type: 8001 len: 15 ANS_OK
05/23/2017 14:24:53.37 id: 0003 seq: 0003 < type: 0100 len: 16 CMD_USER_LIST limit: 0 offset: 0
05/23/2017 14:24:53.37 id: 0003 seq: 0003 > type: 8001 len: 499 ANS_OK
05/23/2017 14:24:53.40 id: 0003 seq: 0004 < type: 000d len: 10 CMD_SVR_GET_PARAMS parameter_id: 0';
my $regex = qr/([\d]{2}\/[\d]{2}\/[\d]{4})[\s]([\d]{2}:[\d]{2}:[\d]{2}\.[\d]{2})\sid:\s([\d]{4})\sseq:\s([\d]{4})[\s<>]*type:\s([\da-f]{4})\slen:[\s]*([\d]{2})\s([\w]*)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}